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1 Ruskin software
Use the Ruskin software to do the following:

Configure and enable multiple sensors
View your datasets graphically
Export your data in various formats
Analyse your data
Change the calibration coefficients 
Perform user calibration
Contact RBR

RSK files generated by Ruskin contain contain raw measurement data, firmware and software versions, dates and 
times, sampling settings, power settings, measured and derived parameters, errors and events, other diagnostic 
information. They can be read directly in Matlab, or exported to Excel, OceanDataView®, or text files. 

Find Ruskin software for Mac and PC on the USB stick included with your instrument, or visit the RBR website to 
download the latest version. 

The most recent software updates, release notes, Ruskin user guides, instrument guides, and quick start guides are 
available from the Help menu in Ruskin.

https://rbr-global.com/products/software/
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2 Ruskin interface
Ruskin software has a user-friendly interface which consists of a Toolbar and three main windows: Navigator, 
Properties, and Plot.

In the Navigator window, you will find the list of instruments connected to Ruskin, as well as MLM and winches (if 
applicable) and datasets. 

When an instrument on the list is selected, the Properties window displays four tabs with information related to this 
instrument: Configuration, Information, Calibration, and Parameters. Use these tabs to configure your deployment, 
check the calibration certificates, and verify your parameters.
The data plot will appear in the Plot window below if the realtime option is available and selected for this instrument, or 
if you click the Fetch button    on the far right of the toolbar. 

Click-and-drag window tabs to rearrange the windows within Ruskin, or move a window outside of Ruskin. Hover over a 
side of a window, and when the cursor becomes a two-way arrow , move it to adjust the window size. 
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Click the Close  button in the top right corner to close a window. For example, you can close the Navigator
window to have a better view of the Properties. The closed window icon will appear on the sidebar (in this case, 

Navigator ). Click the Multiple windows  button above the closed window icon to re-open it. 

Double-click a window tab to maximise that window, and double-click the tab again to return it to the original size. 

Alternatively, use the Single window  and Multiple windows  buttons. 
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The Toolbar at the top left above the Navigator window has four dropdown menus. If you are using a Mac computer, it 
appears as follows:

On a Windows PC, the Toolbar looks slightly differently:

The rest of the interface is the same between the two systems. 

.

.

2.1 Ruskin / Options
On your Mac, go to the Ruskin dropdown menu to access information on current software version, set up your 
preferences, or quit Ruskin. Note that the rest of the options on this dropdown menu depend on your operating system 
and are external to Ruskin. 

On your Windows PC, use the Options dropdown menu to set up your preferences. 

When you restart Ruskin, it returns to its original layout. 
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2.2 File
Go to the File dropdown menu to open or close a dataset, export your data, and see the list of available datasets. The 
Datasets menu in the Navigator windows duplicates some of these options for convenience. 

2.3 Instruments
Go to the Instruments dropdown menu to simulate an instrument or update your firmware, or take advantage of the 
utilities.

The Instruments menu in the Navigator windows duplicates some of these options for convenience. 

2.4 Help
Go to the Help dropdown menu to access the latest release notes and technical documentation, provide your feedback, 
check for updates, or to add a beta feature. On Mac, you can also use the Search option. 

Automatic tasks and Utilities are not applicable for sensors.   
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3 Installation
Ruskin is the only piece of software you need to operate your RBR instruments. RBR releases Ruskin software versions 
compatible with Mac and PC (Ruskin Desktop), as well as with iOS® and Android™ (Ruskin Mobile). 

Install the Ruskin Mobile app on your mobile device by going to the Apple App store or Google Play. 

Follow the steps below to install Ruskin Desktop on your computer. 

3.1 Install Ruskin on a PC
You can install Ruskin on a PC that runs the Windows 7, 8, 8.1, or 10 operating system.

The minimum requirements for Ruskin are:
OS = Windows 7
Processor speed = 1.4GHz 
RAM required = 2GB 
Display resolution = 1024x768 recommended 
HDD space for installation = 500MB

The instruments use a USB interface to communicate with Ruskin.

Steps
Connect the USB stick included with your instrument to a port on your computer.
Navigate to the "Ruskin Installation" folder and doubleclick on the file RuskinSetup.exe.
Follow the installation wizard. By default, Ruskin will be installed to C:\RBR.
At the end of the installation, you will see a prompt asking, "Would you like to install the logger driver at this 
time?"
.

.
Click Yes to install the drivers.

.
A shortcut to Ruskin will appear on the desktop and in a Start menu folder.

Realtime sensors will not require USB drivers to operate; they are only required for our standard and 
compact instruments.



You may need to run the setup application as an administrator to install the driver correctly.

The most recent version of Ruskin software can be found at https://rbr-global.com/products/software.

https://rbr-global.com/products/software
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3.2 Install Ruskin on a Mac
You can install Ruskin on a Mac running OS X 10.12 (Sierra) or later.

Steps
Connect the USB stick included with your instrument to a port on your adaptor.
Navigate to the "OSX" folder and double-click on the file Ruskin.dmg.
When the disk image window opens, drag the Ruskin icon into the Applications directory and wait for the copy 
to complete. An application named "Ruskin" will appear in the Applications folder.

.
Right-click on the icon, and select Open.
The dialogue box shown below will prompt you to authorise the opening of Ruskin. 
.

.

.

.

Drag the Ruskin.app application to the Dock.

Always use the default Applications folder as the working directory.

You may need to navigate to System Preferences > Security & privacy to allow the apps downloaded 
from “Anywhere” to complete the installation.


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3.3 Update Ruskin
To take advantage of new features and bug fixes, ensure that you are using the most recent version of Ruskin. 

Find the most recent version of Ruskin at https://rbr-global.com/products/software.
Receive an automatic notification about a new release when you start the application.
Check from within Ruskin by navigating to Help > Check for updates. 
Send an email to support@rbr-global.com, subject: "Ruskin update request", and ask us to add you to the 
mailing list. You will receive an email as soon as the new version is released. 

If you have a broadband connection, simply follow the installation instructions on your computer. Otherwise, request a 
USB stick from RBR.  

.

3.4 Uninstall Ruskin
Uninstall Ruskin only if you no longer need to manage RBR instruments from your computer.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation program 
deletes the older files before installing the newer ones. For more information, see Update Ruskin.

Uninstall Ruskin on a PC, Windows 7, 8, 8.1, or 10
Go to Start > Control Panel > Programs.
Under Programs and Features, click Uninstall a program.
Find Ruskin on the list.
Click Ruskin to highlight it.
Click Uninstall.

Uninstall Ruskin on a Mac, OS X 10.12 or later

Move the Ruskin application from Applications to the Trash.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation 
program deletes the older files before installing the newer ones. It does not delete any Ruskin data files or log 
files.



Removing Ruskin will not delete your data files or your diagnostic logs.

https://rbr-global.com/products/software
mailto:support@rbr-global.com?subject=Ruskin%20update%20request
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4 Support
You can get in touch with RBR in several different ways:

Send us an email.  For technical questions, use support@rbr-global.com, and for general inquiries, info@rbr-
global.com.

Contact us via the website at https://rbr-global.com/about-rbr/contact-rbr.

Call us at +1 (613) 599-8900.

Send us a bug report from within Ruskin itself. 

The Help menu on Ruskin offers access to technical documentation, feedback forms, and software updates.  On Mac, 
you can also search for Ruskin menu options. 

When experiencing an issue, look for a solution under the Help menu before contacting RBR. 

mailto:support@rbr-global.com
mailto:info@rbr-global.com
https://rbr-global.com/about-rbr/contact-rbr
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4.1 Search on Mac
If using a Mac computer, you can take advantage of the Search option.

In the Search field under Help, type in a word, part of the word, or even a single letter to open a list of matching items.

The top half of the list pertains to Ruskin, while the bottom part comes from the Mac environment.

Scroll down the Ruskin list and select an item to locate.  Ruskin will open the toolbar menu and point to the option in 
the dropdown menu. 

You can execute the located option right away.
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4.2 Release notes
Click on Help > Release notes to open the Welcome window. It will outline new features, improvements, and bug fixes 
associated with each release version.

Click the link at the bottom left to see the full history of the release notes. The link will take you to the RBR support
page.

Alternatively, scroll down to see brief recaps of the release notes from all previous versions. 

Click the x to close the Release notes window and return to the Navigator mode. 

https://docs.rbr-global.com/support/ruskin/release-notes
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4.3 Documentation
Click on Help > Documentation to open the menu tree. Browse through a variety of guides available for instruments 
and accessories. 

.

Please note that you can always access the most current revisions of RBR documents on the RBR website.  

4.4 Comment on Ruskin
There is an advantage to sending a bug report from within Ruskin because this allows you to include the diagnostic 
logs, RSK datasets, screenshots, and any other files that could help us reproduce the problem and find the solution as 
quickly as possible. Follow the steps below. 

RBR#0003296revP

https://rbr-global.com/support/documentation/
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Steps
Click on Help > Comment on Ruskin... . The Feedback to RBR form will appear.
Enter your identification information. 
Enter a brief summary of the problem. 
Provide a detailed description (serial number for the instrument, overview of the problem, deployment details, 
initial tests, and, for software bugs, steps to reproduce the issue)
Include any attachments, if required. 
Verify all the information entered and click Submit. 

.

4.5 Check for updates
Click on Help > Check for updates to search for the latest software version. 

.If your software is up-to-date, no further action will be required. 

If an update is found, Ruskin will offer to install it. Follow the prompts. Restart Ruskin for the updates to take effect.
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4.6 Feature codes
Sometimes, RBR may release new features to certain users only, as a beta trial. This includes:

Features in early development  
Features supporting a new product, in preparation for the product launch
Features requested by a specific customer

Usually, the goal is to get feedback and improve the feature before its official release. Contact your sales representative 
or RBR support team at support@rbr-global.com if you have questions about your feature code.

Steps
Click on Help > Feature codes... 
The Feature codes window will appear. 

Enter the feature code provided by RBR.
Click ADD.

If the code is correct, Ruskin will save the feature in the local database and enable it. In most cases, you will have access 
to the new feature immediately, without restarting Ruskin. Otherwise, you will receive any additional instructions at the 
time when you receive the feature code.  

Errors
The feature code is not valid. 
This error may indicate the code was entered incorrectly or it is not compatible with the current version of 
Ruskin.
The feature code is already enabled.
This error may occur when another user has already activated this code. 

mailto:support@rbr-global.com
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5 Quick start - Ruskin Desktop
Ruskin Desktop version is designed for computers and laptops. It generates dataset files which include raw 
measurement data, firmware and software versions, dates and times, sampling settings, power settings, measured and 
derived parameters, errors and events, calibration coefficients, and diagnostic information, offering the fullest Ruskin 
experience. 

.

5.1 Simulate an instrument
Ruskin can simulate most instruments and sensors that RBR produces. We recommend that you experiment with 
different simulated options before enabling a schedule for your actual deployment. This practice will also help you 
become more familiar with how an RBR instrument interacts with Ruskin and how to configure its settings and 
features. Work with simulated instruments the same way as you work with a real RBR instrument, configuring, 
calibrating, and fetching data.

.

Steps
From the Instruments menu, click Simulate an instrument. 

The Configure simulated instrument dialog box will appear.

Click your instrument family and make your selections. 
.

Depending on the instrument selected, the Options dropdown menu may contain | fast sampling rates, 
| tide and | wave variants, tilt, or no options at all (in that case, the menu will be greyed out). 


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3.

.

.
Click OK to proceed.
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4.

5.

6.

Your instrument will appear under Instruments in the Navigator view. Simulated instruments will have a prefix 
"sim" in the front of their name.
.

The instrument properties will be displayed on the right, under four tabs.
.

The Configuration tab displays sampling mode and speed, serial connection details, and external power 
options
The Information tab includes general details, such as the instrument model, generation, serial number, 
firmware version, power source, and the channels
The Calibration tab allows access to the current calibrations for each channel in the instrument
The Parameters tab outlines default values used by the sensor when performing computations and 
derivations

Familiarise yourself with the instrument by changing configuration options and comparing deployment 
estimates. Select the desired configuration using the dropdown options or entering the values manually in the 
fields provided. The data plot will appear at the bottom of the screen.  
Manage multiple instruments by switching between them in the Navigator window. 

To remove a simulated instrument from Ruskin, right-click it in the Navigator window, and select Disconnect 
from instrument. You can also use the Instruments menu.
 Alternatively, simply close its Plot tab by clicking the X. The instrument will disappear from the list.


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5.2 Deploy an RBR sensor
Before using your RBR sensors, you may want to experiment with different options by simulating your instrument on 
Ruskin. When you are ready to use your physical RBR instrument, follow the steps below to ensure that you measure 
exactly what you want on the first attempt. 

The only two parameters needed to operate your sensor in streaming mode are the streaming speed, and the serial 
baudrate. The sensor will begin streaming data as soon as power is provided. 

The factory streaming speed is the fastest that the sensor is rated for, e.g. | fast32 will be set to 32Hz.
The factory baudrate is 9600.

Steps
Connect your RBR sensor to your computer using a serial interface or a serial-to-USB adaptor. 
The instrument will appear in the Navigator view after a few seconds.
Click on the instrument.
Its properties will appear to the right, grouped under four tabs:

The Configuration tab displays sampling mode and speed, serial connection details, and external power 
options
The Information tab includes general details, such as the instrument model, generation, serial number, 
firmware version, power source, and the channels
The Calibration tab allows access to the current calibrations for each channel in the instrument
The Parameters tab outlines default values used by the sensor when performing computations and 
derivations

The Plot window located at the bottom of the screen will display realtime data streaming from the sensor.

Change the parameters using the on-screen controls and they take effect immediately. All settings persist over power 
cycles.

RBR realtime sensors will begin streaming data as soon as power is provided.

.

.

Ruskin automatically saves the data streamed or fetched from your sensor. 

Go to Preferences to change your default location for RSK files.  

See RSK files for the file naming conventions. 

RBR#0003296revP

Ruskin supports connection baudrate options from 1200 to 115200.
These baudrates do not need to be set in Ruskin for Ruskin to detect an instrument. Ruskin scans all available 
ports with available baudrates to identify RBR instruments. 



The RBR realtime sensors can operate in streaming or polled modes. To set up the polled mode, you will need 
to communicate with your instrument using a serial terminal. See the OEM commands reference section for 
details.


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6 Connections
Use the Connections tab to view and manage devices connected to your computer via physical ports or Ethernet.

In the Navigator window, click Instruments.  The Connections tab will open on the right. The table will include ports, 
statuses, RF latency selections, and the device type for each connected device. 

.

.

Column Information

Port If your instrument is plugged in to your computer, this column will identify the physical port by 
name, such as "COM5" (if using Windows) or by its address, such as "/dev/
tty.usbmodem141101"  (if using MAC OS). 

Status The column will display a success message, such as "Connected to RBRconcerto³ 209681", or 
an error message, such as "Unable to connect to host".

RF latency (s) From the dropdown menu, select a value up to 29 seconds.  The selected value will extend the 
allowable time for an instrument to respond to a command. Use this option when on a long 
cable or slow Wi-Fi connections.

Device The column will display the device type for each connected device:
Logger: Instruments connected via USB, serial (RS-232), or TCP connections
RS-485: Instruments connected via serial (RS-485) connections
GPS: NMEA streaming devices
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Connect your RBR sensor to your computer using a serial interface or a serial-to-USB adaptor.

As soon as you plug in an instrument, Ruskin will detect it and add it to the list. 
.

Click on one of the instruments to switch to its Configuration tab.  
.

If you unplug an instrument, the port will remain enabled as long as the port checkbox remains selected. Ruskin will 
automatically reconnect to the instrument when it is plugged back in. 

Deselect the checkbox next to your instrument to disable transport to its port.  After this, Ruskin will not detect any 
instrument plugged into this port.
.

To restore transport, reselect the checkbox.  Your  instrument will re-appear in the  Navigator  window.
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7 Configuration
Use the Configuration tab to set up your deployment parameters. 

After adjusting any parameters during deployment, verify that they meet your requirements. To return to previous 
settings, click Revert settings. 

To save new settings, click Update instrument.  New values will replace all previously set deployment parameters. 

If you disconnect an integrated sensor from the host instrument to use independently, click Configure as sensor before 
reintegrating, to set up compatible baudrate and sampling speed.  To return to previous settings, click Revert settings.

7.1 Update firmware
Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised. 

If a newer version is available and this update is critical, the Update firmware button and a warning message will 
appear at the top of the Configuration tab. 

See Critical firmware updates for details. 

You cannot use Revert settings after clicking Update instrument.  Once the settings are saved to the 
instrument, you will need to restore old values manually and update the instrument again. 


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7.2 Power
The Power section includes external power options for the RBR realtime sensors. These include RBRfermata and 
RBRfermette3 underwater battery canisters with various battery chemistries available. The RBRfermata uses D-type 
batteries, and the RBRfermette3 uses AA cells.

AA-type batteries (RBRfermette3)

Name Chemistry Voltage (V) mAh*

Lithium thionyl chloride Li-SOCl2 3.6 2700

Lithium iron Li-FeS2 1.5 3500

Alkaline Zn-MnO2 1.5 2500

Li-ion Li-NiMnCo 3.6 750

Nickel metal hydride Ni-MH 1.2 2400

*The nominal capacity of each type of battery is given at room temperature. .

D-type batteries (RBRfermata)

Name Chemistry Voltage (V) mAh*

Lithium thionyl chloride Li-SOCL 2 3.6 18400

Alkaline Zn-MnO2 1.5 16000

Nickel metal hydride Ni-MH 1.2 10000

*The nominal capacity of each type of battery is given at room temperature.
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7.3 Sampling
The  Sampling section includes three fields: Mode, Speed, and Rate, as well as several optional fields available with 
certain sampling modes. 

Mode
Most RBR realtime sensors can only operate in Continuous sampling mode. However, the RBRcoda3 D | tide16 and 
RBRcoda3 T.D |  tide16 also support Tide sampling mode, whereas RBRcoda Tu, RBRtridente, and RBRquadrante support 
Aggregate sampling mode. 

Speed and Rate

These are the only two parameters you need to configure Continuous sampling mode.

Check Speed to select the sampling Rate in Hz from the dropdown menu. The default option is always the highest 
instrument rating; for example,  | fast16 will default to 16Hz. 
.

.

Uncheck Speed to enter the sampling Rate manually in hours, minutes, and seconds (HH:mm:ss format). The fastest 
rate to enter manually is 1s. Type the numbers in, or use the up and down arrows.
.
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When operating in Tide sampling mode, you need to configure two more parameters: Duration and Interval.

The RBRcoda3 D | tide16 and RBRcoda3 T.D | tide16 sensors average a burst of pressure readings and stream only the 
resulting average. 

Duration specifies the time range over which to average. It must always be longer than Speed.

Interval is the repetition period for performing the averaging. It must always be longer than Duration.

In the example shown, the sampling rate selected is 16Hz (16 samples per second).

The instrument will be sampling for a duration of one second, then pause and average the sixteen samples collected.

The sensor will stream only one sample, averaged over the sixteen samples collected during the period of the Duration 
(one second) and remain paused for the time of the Interval (five minutes).  
After the interval ends, the sensor will start sampling again, repeating the same cycle. 

At every Interval, the instrument records only one sample, averaged over all samples collected during the 
period of Duration. The rest of the samples are discarded after averaging is performed. 



Measurement period, Measurement count, and Aggregation period

When operating in Aggregate sampling mode, a set number of measurement (a measurement burst) are taken at each 
period. Thus, you need to configure Measurement period, Measurement count, and Aggregation period. 

Measurement period sets the internal sampling rate of your sensor.  Measurement count is the number of 
measurements within the burst, with its maximum being 320 regardless of the sampling rate. Thus, at 32Hz, the 
maximum Aggregation period is 10s. 

The sensor will collect data at the specified rate over the specified Aggregation period, until the number of collected 
samples reaches Measurement count, and then average those samples to produce a single value to store on the 
instrument. In the example shown, the RBRtridente will sample at 32Hz and collect 320 samples in 10s, average these 
320 samples to produce a single value, and immediately start sampling again. There is no gap between the bursts. 

RBR#0003296revP
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Serial offers possible baudrate options for your serial connection. The factory baudrate is 9600.

Select the output format for the realtime data from two dropdown options.
Compact
All values are shown to four decimal places, with no units displayed.

Compact (Highest resolution)
All values are shown to the number of decimal places required to adequately represent them (not limited to four 
decimal places), with no units displayed.

Ruskin automatically saves the data streamed from your sensor. Go to Preferences > General to change your default 
location for RSK files.  

See RSK files for the file naming conventions.

RBR#0003296revP

.

7.4 Options
Three dropdown menus are available for the RBR sensors in the Options section: Realtime, Serial, and Format.  
Realtime specifies your external streaming connection.  Select Serial to stream live data over RS-232. Sensors will 
begin streaming data as soon as power is provided.
Otherwise, select None and use the fetching feature. 
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7.5 Ranging sensors
The Ranging sensors section has two dropdown menus, Sensor and Range. 

The former displays the name and index of the channel, which for the RBRcoda Tu is Turbidity (1) and Turbidity (2). 
The latter specifies the gain level used for the deployment. The units of measurement are NTU (Nephelometric Turbidity 
Units). 

Set Range to Auto to enable the auto-ranging setting. Your instrument will change the gain setting on the front-end 
amplifiers to the range most appropriate for its environment.  To display the range change events, select Diagnostic

from the dropdown under the Events button  in the Plot window toolbar.

Range change events are displayed as "RANGE XX Units" where XX indicates the current range and units are the units of 
measurement, for example: RANGE 500 NTU. For  | fast sampling, where the change may be occurring over a number of 
samples, the label will read, "RANGE CHG", followed by the final range change event.

Alternatively, select a fixed gain setting to maintain the same setting throughout your deployment. 

7.6 Configure as sensor
All RBR realtime sensors may be integrated with a standard RBR instrument, such as the RBRconcerto3 or RBRmaestro3, 
provided it has a channel set up for that particular RBR sensor. This configuration is determined at the time of order and 
cannot be changed post-production. 

Typically, RBR multi-sensor instruments are shipped with all sensors already installed and ready to use. There may be 
situations when you remove a pre-installed sensor from the RBRconcerto3 or RBRmaestro3 and use it independently, 
changing its setting while doing so. In this case, do not re-install the sensor back on the host instrument immediately 
after you are done. First, ensure its baudrate and sampling speed are compatible with integration. To do so, click the 
Configure as sensor button. 

Failing to perform this operation prior to attaching the sensor to the host instrument may yield poor results as 
the host instrument will be unable to communicate with the sensor.


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8 Information
Use the Information tab to view general information for each of your instruments, such as as model, generation, serial 
number, firmware version, power source, and the channels. 

.

.

In the Instrument details section, find the model, generation, and serial number for your instrument, as well as the 
firmware version installed and link used. 

.
Refer to the Power section for the power source, power type (internal or external), and voltage. 

.

Under Channels, confirm measured and derived parameters for your instrument. 

If you see a warning sign on the Calibration tab, certificates for one or more sensors are out of date.

.

When online, click Download to obtain the PDFs of the most recent calibration certificates for each channel. 

.

.
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9 Calibration
The Calibration tab displays calibration coefficients for each parameter, and the date and time of the last calibration.

Select a sensor from the Parameter dropdown menu to display its calibrations.

RBR calibration certificates contain calibration equations, coefficients, and residuals for each sensor.

The date of the latest calibration is always displayed. As an extra reminder, you can select the Check calibration expiry 
checkmark. A warning sign will appear when your calibration certificate is out of date. 

RBR recommends calibrating your instrument before any critical deployment, periodically once a year, or if you suspect 
the readings to be out of specifications. 

Discuss your calibration requirements with RBR. In some cases, the instrument may need to be returned to RBR to have 
it checked and recalibrated.

To contact RBR for our current calibration fees, click Request calibration quote. A Request for quote dialog box will 
appear. 

mailto:support@rbr-global.com


RBR#0003296revP 33

Verify that all information is correct and click Submit.

Simple calibration controls

When using the simple version, you will be able to view and edit only the main calibration coefficients, displayed as "C" 
values: C0, C1, C2, C3. 
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Advanced calibration controls

When advanced calibration controls are enabled in Preferences > General, you will be able to view and edit both main 
and dependent coefficients. Dependent coefficients are displayed as "X" values: X0, X1, X2, etc. 

You can edit the coefficients. As soon as you make a change and move to another cell, a new calibration date will be 
displayed. Also, Store calibration and Revert calibration buttons will become active. 

Use Store calibration to save the new values.

Use Revert calibration to recover to the original coefficients if you have not already saved your changes to the 
instrument. 

Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will be lost 
once your session is closed. 



You cannot use Revert calibration after clicking Store calibration. Once the coefficients are saved to the 
instrument, you will need to restore old values manually and save them again. 


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10 Parameters
The Parameters tab displays all the parameters the RBR instrument may need for calculating derived channels.

If your instrument can measure a parameter, it will use the measured value. Otherwise, you can enter the necessary 
values manually, and they will take effect immediately. 

For example, you always need atmospheric pressure and water density for derivation of depth. Default values in Ruskin 
correspond to sea level and sea water. Therefore, it is especially important to adjust these parameters when working at 
high altitudes in fresh water.

Enter atmospheric pressure (in dbar) and water density (in g/cm3) manually in the table under the Parameter tab. If not 
entered, default values of 10.1325dbar and 1.0281g/cm3 will be used. 
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11 Preferences
On your Mac, access Preferences from the Ruskin dropdown menu in the top toolbar.

On your Windows PC, use the Options dropdown menu to set up your preferences. 

.

Factory-set global defaults require no changes in most situations. However, as you learn more about what Ruskin can 
do, you may want to change some of these settings to better suit your requirements.

The global preferences include:
Derived channels (applies to some legacy instruments)
Facility (authorised users only, requires login)
General (download locations and options, sampling and calibration controls, export options)
Plotting (channel visibility and channel colours)
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11.1 General
Use the General preference page to set up file locations, language, download options, sampling and calibration 
controls, and export options. 

File location

You can control where RSK files, realtime RSK file, and log files are stored by default. 

Specify these locations before downloading any data by typing in a directory name or by browsing. 

You can click Apply to save your changes without closing the dialogue box.
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RSK files are the datasets obtained from your instrument. 

Realtime RSK files are generated when a connected instrument is streaming or when you enable fetching mode on the 
instrument.

Log files are generated by Ruskin and help when diagnosing issues. These files are automatically attached to issues 
generated using the Comment on Ruskin feature.

You can change where future files are stored by default at any time. When done, click Apply or Apply and close.  The 
changes will take effect immediately.

Language selection

Ruskin is available in six languages: English, French, Spanish, Simplified Chinese, Korean, and Japanese.

Select your language from the dropdown menu and click Apply or Apply and close. Ruskin will need to restart for the 
changes to take effect. 

Download options

Select the appropriate checkboxes to change your download preferences.

When done, click Apply or Apply and close.  The changes will take effect immediately.

RBR recommends storing your datasets on a local drive rather than a network storage drive. Cloud storage 
options such as GoogleDrive and Dropbox may extend download times.



The Enable download schedule UI checkbox is only for legacy instruments.
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Sampling control

 Select the checkbox to enable advanced controls when setting up your sampling options.

With simple controls, you will select Speed, Duration, and Interval from pre-defined options in three dropdown 
menus.  When advanced controls are enabled, you will be able to enter these parameters manually and achieve a more 
precise setting. 

When done, click Apply or Apply and close.  The changes will take effect immediately.

Calibration control

 Select the checkbox to enable advanced controls when setting up your calibration options. 

With simple controls, you will be able to view and edit only the main coefficients (C). When advanced controls are 
enabled, you will be able to view and edit all main and dependent calibration coefficients (C, X) for any channel.

When done, click Apply or Apply and close.  The changes will take effect immediately.

Export options

Select the checkbox to enable raw data export. Use this option for downloading your RSK file when storage space is 
limited or expensive. The dataset will be exported in the most compact raw binary format. 

When done, click Apply or Apply and close.  The changes will take effect immediately.
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11.2 Plotting
Adjust default settings for the graphical display in the Plot view. Manage selections in Channel visibility and Channel 
colours, and apply them globally.

Channel visibility

The Channel visibility tab displays many options to hide or show specific information.

You can click Apply to save your changes without closing the dialogue box.
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Opt for displaying errors and events for a more informative graph, or hide them for a cleaner view. 

Select the By default, hide all measured channels checkbox to display only derived channels.

Select the By default, hide all derived channels checkbox to display only measured channels.

Otherwise, pick and choose channels to display or hide. 

When done, click Apply or Apply and close.  The changes will take effect immediately.

.

Channel colours

The Channel colours tab allows you to choose a different colour for each channel that is shown for information 
currently running in Plot view, or from an opened dataset. Select from the list of pre-defined options or create your own 
colour.

When done, click Apply or Apply and close.  The changes will take effect immediately.

You can override visibility preferences in the Plot view for any particular graphical display.
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12 RSK files
The RSK file is a single file database based on SQLite that allows us to have large files with high-speed access to any part 
of the dataset. RSK files have different types and versions, which reflect historical changes to the underlying dataset 
structure. To upgrade the version of an older RSK file, go to File info tab. 

RBR provides open-source RSKtools toolboxes for both Matlab (RSKtools) and Python (pyRSKtools) to read, post-
process, visualise, and export RSK files.

RSK files can be exported to Excel, OceanDataView®, or text files.

RSK files contain raw measurement data, firmware and software versions, dates and times, sampling settings, power 
settings, measured and derived parameters, errors and events, other diagnostic information. 

Datasets in the Desktop storage format allow changes to calibration coefficients. GPS mapping for full RSK 
files relies on manually added location points.
This file format is available for RBR standard and compact instruments. 
Datasets in the Mobile storage format support charting and GPS tracking. They do not allow changes to 
calibration coefficients. 
This file format is only available for RBR standard instruments. 
For datasets obtained via streaming or fetching, the RSK format is Realtime. Their names contain the "realtime" 
label.  
This file format is available for RBR standard instruments and RBR realtime sensors when in streaming mode, 
and for all instruments when fetching. 

To identify the type of the RSK file, go to the File info tab.  

..

File naming convention for realtime datasets

By default, realtime dataset names are composed of the following information:
The instrument serial number: six digits
The date of the download (YYYY-MM-DD): eight digits
The time of the download (HH-MM in the 24-hour format): four digits
The "realtime" label, indicating the data were streamed or fetched from the instrument

For example, the file named 209682_20220531_1408_realtime.rsk contains the dataset for a streaming instrument with 
a serial number of 209682; the data were saved on May 31, 2022 at 14:08 (02:08pm), local time.

The data streamed or fetched from your instrument are automatically saved to your computer. Go to Preferences > 
General to change your default location for realtime RSK files.  

.

The file extension is .rsk; it indicates the Ruskin file format and must not be edited. If you change it, your new 
file extension will become part of the dataset name, and the .rsk extension will be appended.



http://rbr-global.com/support/matlab-tools
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13 Realtime data format
Sensors will begin streaming data as soon as power is provided. Below are example strings of data from each variety of 
the RBR sensors: 

Instrument Example data Channels list

RBRcoda3 T.ODO 29000, 23.2868, 200.4000, 
93.0000, 245.0000, 29.6900

Timestamp (ms), Temperature (°C), concentration 
compensated for salinity (μmol/L), saturation (%), 
concentration uncompensated for salinity (μmol/
L), phase (°)

RBRcoda3 T 29000, 23.2868 Timestamp (ms), Temperature (°C)

RBRcoda3 D 29000, 10.2484 Timestamp (ms), Pressure (dbar)

RBRcoda3 DO 29000, 98.8754 Timestamp (ms), Saturation (%)

RBRcoda3 T.D 29000, 23.2868, 10.2484 Timestamp (ms), Temperature (°C), Pressure (dbar)

RBRcoda3 PAR, 
RBRquadrante 

1250, 38.6671142 Timestamp (ms), PAR (μmol/m2/s)

RBRcoda3 rad, 
RBRquadrante 

1250, 22.0217241 Timestamp (ms), Irradiance (μW/cm2/nm)

RBRtridente 3  
3550, 

2.6534132, 22.0217241, 
1.9596633

Timestamp (ms), backscatter (m-1), chlorophyll a
(µg/L), fDOM (ppb)

RBRcoda3Tu 29000, 35.6674542 Timestamp (ms), Turbidity (FTU)

.

The timestamp is the number of milliseconds since the time of the first sample, and so the first sample is always 
timestamped as zero. The timestamp will restart any time the CPU resets or if the following sample parameters are 
changed:

Changing the sampling period
Changing the sampling mode
Changing the burst length or burst interval
Turning a channel on/off (advanced users only)

The values following the timestamp are all the enabled channels. To identify which channels are enabled and their 
order in the string you can use the command outputformat channelslist.

Example

>> outputformat channelslist

<< outputformat channelslist = temperature (C), O2_concentration (umol/L), 
O2_air_saturation (%), uncompensated_O2_concentration (umol/L)
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14 Datasets
Datasets are RSK files generated by Ruskin and have an .rsk extension. You can view and analyse your data using the 
options below. 

Go to the File dropdown menu to open or close a dataset, export your data, and see the list of available datasets. 

The Datasets context menu in the Navigator windows duplicates some of these options for convenience.

Explore the contents of your datasets in the Properties window.

When a dataset on the list is selected, the Properties window displays four tabs with information related to this 
dataset.

Use these tabs to analyse your data, check the calibration certificates, and verify your parameters. 
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1.

2.

14.1 Open dataset
Open any stored dataset from the File menu in the top toolbar or from the Datasets menu in the Navigator view. 

Steps
Click File > Open dataset.

Alternatively, right-click Datasets in the Navigator view and select Open dataset. 

A browsing window will appear. Double-click the .rsk file you want to view, or select the file and click Open. 
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3.

4.

The name of the dataset appears and is highlighted automatically in the Navigator view. The Properties view 
changes to the dataset, with four tabs: Analysis, Overview, Channels, and File info.

The data in the file will automatically appear in the Plot view.

To close a dataset, go to File > Close dataset. Alternatively, right-click the dataset name in the Navigator view 
and select Close dataset. 
 Alternatively, simply close its Plot tab by clicking the X. The dataset will disappear from the list.


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2.

3.
4.
5.

14.2 Export
Use the Export option to share your data with others or analyse your data using other software. Datasets can be read 
directly in Matlab with our toolkit RSKtools, or exported to Excel, OceanDataView®, or text files. 

Steps
File menu > Export, then hover to open a set of submenus.

or right-click the dataset in the Navigator window, then hover to open a set of submenus.

Select the appropriate export format (Microsoft Excel, netCDF/netCDF profiles, Text, OceanDataView 
spreadsheet, or Raw binary). 

.
If exporting annotations, select the category: Full profiles, Downcasts, or Upcasts.
Specify a location and a name for the data file. 
Click Save.

For realtime RSK files, the Raw binary export format is not available.

http://rbr-global.com/support/matlab-tools
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14.3 Analysis
Select a dataset in the Navigator view. The Properties view will change to dataset properties, with four tabs: Analysis, 
Overview, Channels, and File Info.

For most realtime datasets, the Analysis tab will only have the Cursor option. For Oxyguard DO sensors, it will also 
include Calibration.

The Cursor view contains statistical information about deployment, as well as information about the dataset channels 
and their values. 

The colour-coding of the channel table matches that of the traces in the Plot window. To change the colour settings for 
your chart, go to Preferences > Plotting > Channel colours.  
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Move the black cursor ("double lollipop") in the Plot window to display parameter values for each sample selected.

Every time you move the black cursor, going form sample to sample, the table above the plot will display the 
information for this particular sample.
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Select Display statistics checkbox to determine the average value and standard deviation over a range of samples. 
Change the number of samples to average using the up and down arrows.

The table will display the averaging data. The averaging interval will be highlighted in the plot.

When the Calibration view is available, you can recalculate your coefficients for the DO channel. See User calibration.
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14.4 Overview
Use the Overview tab to view general information for each dataset, such as instrument details and deployment events. 

To make a note about this dataset, enter your comment in the field provided and click Save comment.

.

14.5 Channels
The Channels tab has two options: Information and Parameters. 

Information

The Information page displays two tables: Measured channels and Derived channels.

Measured channels include measured parameters with their units of measurement, the sensor manufacturer, and the 
range setting (if applicable). 

Derived channels include all available derived parameters with their units of measurement and the methodology used 
to calculate them.
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Parameters

The Parameters tab displays parameters necessary to calculate derived channels and the method used for calculation. 
This page is not editable for realtime datasets. 
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14.6 File info
The File info page displays the dataset name and download location, Ruskin version used when it was obtained, file 
structure, and size.  

The Structure label reflects the RSK file format, which can be Desktop, Mobile, or Realtime.

.Ruskin checks the dataset for compatibility with the newest version of Ruskin software. If the file requires updating, a 
warning message and an Update button will be displayed.

Click Update. It may take several minutes for it to complete. RBR strongly recommends that all datasets are updated 
and meet compatibility requirements.

The RBR smart streaming sensors generate RSK files in the Realtime storage format only. 

Failing to update your dataset may result in odd graphical displays and incorrect reporting of the sample 
values.


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15 Plot window
Use the Plot window to view graphical displays of your datasets or live data. When viewing live data, the instrument 
must be attached.  

Each channel appears as a different colour in the plot. These colours are specified under Preferences > Plotting and can 
be changed only there. 

Move the black "double lollipop" cursor from one sample to the next to display parameter values for each sample 
selected. Drag it with your mouse, or use the arrow keys on your keyboard as follows:

To move by one data sample, press right or left arrow 
To move by a hundred of samples, press Shift + right arrow or Shift + left arrow
To move by ten thousand of samples, press Alt + right arrow or Alt + left arrow
To move by millions of samples, press Shift + Alt + right arrow or Shift + Alt + left arrow

For the datasets, these values will appear in the Properties window above (see Analysis).  For live data, they will be on 
the side of the plot.

The graphical display for each dataset or instrument will be in its own tab.  The dataset file name or the instrument 
model and serial number will appear at the top of the tab. Simulated instruments will have "sim" in front of their name. 
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A toolbar at the top right of the Plot window contains various buttons to help you customise, explore, and export the 
graphical display. The buttons selection changes depending on what is displayed in the tab. Hover over a button to 
display its name and function. 

A downsampled representation of the dataset appears in the thumbnail view, along with an indicator of the current 
plotted time range. 

Position the indicator by clicking on the thumbnail view and dragging the indicator. Resize the indicator by dragging the 
edges left and right. It will zoom the main plot along the time domain to match the new indicator size. See Zoom 
controls for more scaling options. 

.

When you close and re-open a dataset, it will retain your latest settings (channel visibility, zoom, plot style (plot-by-time 
or plot-by-depth), annotation selection, and display style (lines or markers).

Double-click anywhere on the main plot to return to the full-chart view.

.

.

The thumbnail view always shows the plot-by-time data, even if the plot is switched to the plot-by-depth 
mode.



Go to Appearance controls to change your selection of lines and markers. .
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16 Dataset plot toolbar
Use the plot toolbar to adjust the display of an open dataset. 

16.1 Annotation controls
Annotations are information messages added either by users or by the instrument. 

16.1.1 Select annotation type
Annotation types are divided in two categories: profiling (Profile, Downcast, or Upcast) or non-profiling (Comment, 
Exclusion, Location, or Calibration). Use annotation controls to manage this information and to navigate the plot. 

Type Function

Profile, Downcast, Upcast Identify profiling

Comment Add a note to your data

Exclusion Remove a non-representative interval from analysis

Location Add in latitude/longitude coordinates for RSK files to track locations of 
data logging

Calibration Calibrate the ODO sensor
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Open the Filter dropdown menu to select the annotation type to display. The number of annotations for each type will 
be indicated. 

Select an annotation type. The plot will centre on the first item in the selected category. For example, when you select 
Profile, the plot will move to the first profile. 

If you switch the filter to another annotation type within the same category (for example, Profile to Upcast), the plot 
will not change. If you switch to a type from another category (for example, from Profile to Comment), the plot will 
move to the first annotation in the new category (for example, to the first comment). 

16.1.2 Navigate between annotations

Use the Navigation buttons  to navigate between items within the selected category. 

.

Navigation controls
Move from one annotation to another by clicking the left and right arrows.
Jump all the way to the beginning or end of the list by using the end-left and end-right arrows.
Alternatively, manually enter the number in the Index field to go to that particular annotation. 
Double-click an annotation to centre and zoom in the plot at that particular area. 
.

The navigation buttons will be activated if there is more than one item in the selected annotation type. 
Otherwise, the plot will centre on the only item available. 



Double-click anywhere on the main plot to return to the full-chart view.
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1.

2.

16.1.3 Create new annotation

Click the Create annotation button  and follow the steps below. 

Steps
Select the type of annotation to create, for example, Comment.

The cursor in the Plot window will become a two-way arrow .

Click on the main plot to identify a single point to comment, or click and drag the cursor left or right to select an 
interval. When you release the click, an editable tooltip will open.

The tooltip controls include Left and Right arrows  , Delete  , Export region  , Save  , 

and Close  . 

The Profile tooltip also features Up and Down arrows  for adding upcast and downcast profiles. 
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3.

4.

5.

6.

7.

Enter the necessary information into the fields and save by pressing Enter on your keyboard or by clicking Save 

 on the tooltip. Your new comment will appear in the dropdown list.

Clicking Close  or pressing Esc on the keyboard will close the tooltip without saving. 
.

. 

Click the arrows  on the tooltip to move to the next annotation within the same category. 

Double-click on the annotation bar to zoom in to the range of the annotation. 

Click and drag on the annotation bar to move the annotation. 

Click Delete  on the tooltip to delete the annotation. 
A warning message will appear. 

Click Delete to proceed. This action cannot be undone.

Edit at least one detail in the tooltip before saving. Otherwise, the annotation will be deleted when 
deselected.  Moving or resizing the annotation counts as editing and saving.


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1.

2.

3.

4.

16.1.4 Add profiles
Use the Annotation function to manually add profiles to your dataset.  

Steps

Click the Create annotation button   and select Profile from the dropdown menu.

Click and drag the cursor to select a region.  

As soon as you let go, an editable tooltip will open and a band of a darker colour will appear above the selection, 
indicating that a new profile has been added.

Place the cursor on the edge of this new profile and move it left or right to adjust the size. 

Add a name and click Save  on the tooltip. 
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5.

6.

7.

8.

9.

Use the Up and Down arrows  on the tooltip to identify upcast and downcast regions.
The upcasts and downcasts you added will be displayed in the dropdown menu and highlighted on the plot 
under the parent profile.

Place the cursor at the edge of the added region and adjust its size.

Click on a profile/upcast/downcast to open its tooltip.  

Name each region and save the settings. 

If desired, export your profile to a separate RSK file. To do that, click Export region  on the Profile tooltip 
and follow the steps. 

Only the Profile tooltips have the  Up and Down arrows.

The Export region option is not available on Upcast and Downcast tooltips. To generate an RSK file for 
an upcast or downcast section only, use the Comment annotation to clip the dataset before exporting.


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1.

2.

3.

16.1.5 Export region

Follow the steps below to clip your dataset and export a subset of your data. This function may be useful when you 
need to exclude certain regions. For example, a dataset may contain several deployments if sampling was not paused/
stopped before the new deployment was started. 

Steps

Click the Create annotation button  and select Comment from the dropdown menu.

Click and drag the cursor to select a subset. 

Enter a name in the Title field on the tooltip and click Save  . 

The Export region option is only available for Comment and Profile annotations. 
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4.

5.

6.

Select Export region   on the tooltip.
A dialogue box will open. 

Adjust the name and location for the new dataset file and click Save.  
An Export region message will appear. 

Select No to maintain the full binary values and retain the option of recalibration in the future. 
The clipped dataset will open in a new tab in the Plot window.
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16.2 Cast detection
Ruskin automatically enables profile detection on instruments when a deployment is enabled. There are several criteria 
for enabling this feature.

 The instrument must support the castdetection setting
 The instrument must have a pressure sensor
 The deployment must be configured for | fast sampling (2Hz and up)
 The deployment mode must be configured as either continuous or directional

It is possible to recalculate the casts in a dataset using the cast detection feature in the Plot view. 

Click the Cast detection button  to run a cast detection algorithm based on depth and conductivity to 
automatically generate profiles and casts. A warning message will appear.

If you proceed, Ruskin will find peaks, collect events, and overwrite profiles recorded by the instrument. .

.

16.3 Event visibility

Click the Event visibility button  to turn on and off the visibility of the various levels of events: Error, Warning, 
Information, and Diagnostic. Its colour will reflect the highest level of event severity reported. 

Double-click anywhere on the main plot to return to the full-chart view.
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16.4 Zoom controls
Default scaling of the plot is based on the minimum and maximum values sampled for each channel. Use zoom controls 
to adjust it as needed. 

16.4.1 Horizontal zoom
Horizontal scale options may be helpful to increase or decrease the the time range displayed. It is convenient when the 
dataset is long and thus losing resolution when displayed in the Plot window in its entirety, like in this example. 

Double-click anywhere on the main plot to return to the full-chart view.
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1.

2.

There are three ways to apply changes to the horizontal scale.  The first two will auto-range your chart, ensuring the 
entire vertical domain is visible. The third approach will retain the latest vertical scaling of the original interval. 

Use the Zoom in horizontally  and Zoom out horizontally  buttons. 

 OR

Click on the thumbnail view and resize the indicator. 
The vertical scale will automatically adjust to fit the new range.

3. Hover your mouse over the X-axis, then hold Shift + left click. 
    The cursor will change to a two-way arrow . Drag it right to zoom in or left to zoom out the time domain, 
without changing the data resolution.

Click Reset zoom to maximum bounds or double-click anywhere on the chart to restore the original 
appearance. 





RBR#0003296revP 67

16.4.2 Vertical zoom
Vertical scale options may be helpful when there are erroneously high or low values that make the real data appear 
incorrect, or when there is significant difference in scale between the displayed parameters.

Entire chart

Depending on the zooming method, you may change the scale only vertically, or both vertically and horizontally. 

1. Use the Zoom in vertically  and Zoom out vertically  buttons to increase or decrease the resolution 
of the data displayed.
The resulting display will retain the same horizontal scale. 

OR

2. Hover the cursor and scroll your mouse wheel up and down to change the scale. 
In this case, the horizontal scale will also change (as seen from the thumbnail indicator). The plot will centre where 
the mouse cursor initially was.
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1.

2.

Individual channel

There are two ways to apply changes to the vertical scale of one channel only, which yield the same results.
Hover the cursor over the Y-axis for this channel and scroll your mouse wheel up and down.

OR

Shift + click the Y-axis for this channel and move your mouse up and down.

This particular channel will zoom in and out (in the example below, temperature).  Double-click on the same vertical 
axis to reset this parameter. 

Click Reset zoom to maximum bounds or double-click anywhere on the chart to restore the original 
appearance. 


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1.

2.

3.

4.

16.4.3 Navigation options
After you change the scale, some parts of your chart may end up outside the Plot window. There are several options 
available to navigate it. 

To pan the entire chart horizontally, hold Ctrl + left click and move your mouse left and right.

This action is only possible after already applying some horizontal zoom to the chart.

To pan the entire chart vertically, hold Ctrl + left click and move your mouse up and down. 

To pan one of the channels vertically, click a value on the vertical axis for that parameter (in the example below, 
sea pressure) and move your mouse up and down.

Double-click on the same vertical axis to reset this parameter. 

To freely select any part of the chart, hold Shift + left click and draw the rectangle. The chart will zoom in on the 
selected area, both horizontally and vertically. 
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5.

6.

To keep all  your data within the viewing window, click the Toggle auto-ranging button .  When it is on, all 
profiles within the selected time section maintain their optimal vertical zoom. 

Click again to disable. Disabling the auto-ranging of the axis can be useful for looking at trends in data. 
Zooming in or out of an individual channel will disable auto-ranging for that channel. 

To zoom in to the range of an annotation, double-click on the annotation bar. 

Click Reset zoom to maximum bounds or double-click anywhere on the chart to restore the original 
appearance. 


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16.4.4 Advanced axis controls

Some RBR instruments have multiple parameters of the same type.  For example, your RSK file from the RBRconcerto3 
Tx could have 12 or 24 temperature channels and from the RBRquadrante, up to four irradiance channels. 

By default, Ruskin will use a single axis to display similar channels. To display each similar channel on its own axis, g o 
to Preferences > Plotting > Channel visibility. Deselect the Use single axis for similar channels checkbox. 

Click Apply and close.  These changes will automatically apply to every new dataset. To apply your changes to an active 
dataset, close it and then re-open. 

Both views have their advantages. Below, compare the two displays of the same dataset obtained using an 
RBRquadrante .
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Default settings: single axis

The chart displays four irradiance channels and one irradiance axis. The axis is grey, while the traces related to this 
single axis remain colour-coded.

With the axis panel collapsed, you have a broad view of the chart. 

All four channels have the same scale, which in the example below is 0-5.500µW/cm²/nm. Vertical zoom controls, if 
used, are applied to all these traces as a group. 

Customised settings: multiple axes

The chart has four irradiance channels and four axes, each identified with the same colour as the trace. The 
corresponding wavelength and FWHM will also be displayed; in this example: 560/10, 488/10, 445/10, and 413/10.

Each channel has its optimal vertical scale. In the example below, the scale for the 560/10 is 0-9.000µW/cm²/nm, while 
for the 413/10 it is 0-0.100µW/cm²/nm .

To adjust the vertical scale for each channel individually, hover the cursor over an axis and scroll your mouse wheel up 
and down. See Vertical zoom for other ways to adjust the scale.
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Regardless of the view (single axis or multiple axes), the channel table in the Analysis tab retains individual colours for 
all channels, matching the colour-coding of the traces in the Plot window. 

16.5 Export plot

Click the Export plot button  and select file name and location to save the current view of the main plot to a PDF 
or PNG file. The exported file will contain the graph only and retain all the changes to display active at the moment of 
export: zoom, lines and markers, visible events and annotations, and plotting by depth or time.

16.6 Appearance controls

Select your data rendering type from the Change line type dropdown menu :  Lines, Markers, or Lines and 
markers.

To change the colour-coding settings for your chart, go to Preferences >   Plotting > Channel colours. 
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.

Use the Toggle channel visibility button  to open the dropdown menu with the list of available channels and 
options. Check and uncheck channels to display as desired, or select groups to show and hide. 

.

Select Show raw channels to display measured data with no calibration equations applied. 

.

If no data appears in the Plot view, try changing the rendering to Markers.  Time spans that are larger than 
expected will cause breaks between data points and lines will not be drawn connecting those points, whereas 
markers draw at each individual point.


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By default, the data are plotted by time. Use the Toggle depth plot  button to switch to the plot-by-depth mode. 

The thumbnail view will continue to display the plot-by-time data. 

16.7 GPS map

The Show GPS map button  opens a pop-up window with the GPS map for the plot. Click on the map to display all 
the GPS location annotations recorded in the dataset..

.

GPS mapping for Desktop RSK files relies on manually added location points (see Annotation controls). All location 
points you added using the Annotations feature are stored in the dataset file and can be displayed in Ruskin via the 
mapping functionality.

If there is no depth channel, the plot will use the next pressure or pressure-derived channel starting from the 
bottom of the channel list.


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17 Live data plot toolbar
You can use the Plot window to view a live graphical display of your instrument sampling. All options described in the 
Dataset plot toolbar section apply to live data display. Additionally, three live data buttons appear at the right end of 
the toolbar: Side data panel, Live plot time range, and Fetch. 

Click the Side data panel button  to toggle on and off the data panel to the right of the plot. It shows the file 
location that will be used to capture samples, the number of samples collected, the values of the last received sample, 
and the currently selected sample.  

Click the Live plot time range  button to open a dropdown list of time span options.

For example, select 2 minutes to display the data in the thumbnail view and on the side panel by two-minute time 
periods. 
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You can also choose to display all of the data collected.

Fetching

Live data can come from one of two sources: streaming or fetching. 

Fetching is the action of asking the instrument to take a reading and report it. 

To start fetching, disable the streaming option. Go to Options under the Configurations tab and set Realtime to None. 

Click the Fetch button  to start fetching data. The button will change to Pause . Click the Pause button 
to stop fetching. 

If streaming is selected (Realtime is set to Serial), clicking the Fetch button  will have no effect on the 
plot. 


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1.

18 Firmware updates
Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised. 

18.1 Critical firmware updates
If a newer version is available and this update is critical, the Update firmware button and a warning message will 
appear at the top of the Configuration tab. 

Steps
Click Update firmware.
The Update logger firmware window will appear. It will contain Release notes, outlining the new version 
number, its release date, improvements, and bug fixes associated with this release, and two standard buttons at 
the bottom of the window: Close and Proceed. 
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2. Click Proceed to initialise the update.
The instrument will disappear from the Navigator window during the upgrade. Watch the progress bar at the
bottom of the window for the status.

.

If the upgrade does not complete successfully, go to the Instruments menu and launch the update dialogue.

The Update logger firmware window will appear. Click Proceed again to retry. 

If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from 
the USB port and then reconnect to establish communication.

.

18.2 Routine firmware updates
If the latest update is not critical, Ruskin will not display any warning message. However, you can always check 
manually if a newer firmware warning is available.

Go to Instruments > Update instrument firmware.

The Update logger firmware dialog box will appear. In addition to the new version number, its release date, 
improvements, and bug fixes, there will be two additional sections: Select the instrument to update and Select the 
firmware image. 

Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the 
update process may render the instrument inoperable.


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1.

2.

3.

Steps
From the Instrument dropdown, select the instrument you wish to upgrade.

From the next dropdown, select the latest firmware image.   

Click Proceed to initialise the update.
The instrument will disappear from the Navigator window during the upgrade. Watch the progress bar at the 
bottom of the window for the status. 
.

If the upgrade does not complete successfully, click Proceed again to retry. 
If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from 
the USB port and then reconnect to re-establish communication.

Do not disconnect the instrument until a confirmation message is displayed. 
Disconnecting during the update process may render the instrument inoperable.


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1.

2.
3.

4.

18.3 Manual firmware updates
In certain cases, RBR may supply a customised firmware version, which will not be on the dropdown list. 

Go to the Instruments menu and launch the update dialogue.

The Update logger firmware dialog box will appear.  Follow the steps below to import the firmware image provided by 
RBR and update your firmware. 

Steps
In the Update logger firmware dialog box, click Import.

Browse to the location of the firmware update file. The file will have the extension .rbrfw.
Select the file and click Open.
The file will appear on the dropdown list. 

Click Proceed to initialise the update.
The instrument will disappear from the Navigator window during the upgrade. Watch the progress bar at the 
bottom of the window for the status.  

Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the 
update process may render the instrument inoperable.


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19 Utilities

From the Instruments menu, click Utilities. A dropdown menu will open. 

.

.

Stop instrument upon detection

This is an emergency utility which provides a solution to a rare issue with some legacy instruments. Do not use unless 
instructed by RBR. 

.

The Utilities option is a support tool. Contact RBR before using it. 

mailto:support@rbr-global.com
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1.

2.

Connect to networked device...

This utility allows a device with serial output to connect to your network via Ethernet. This feature supports remote 
management and monitoring of your instruments from anywhere in the world.

Select your network device from the dropdown list.
.

Specify the IP address and port. 
.

.
For the microsalinometer, the port number must be 23. 
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3. Click Connect. 
The Connections tab will display instruments and salinometers connected via Ethernet, alongside with the
instruments physically plugged in to your computer. Their IP address and port will appear in the Port column. If 
an attempt to connect was unsuccessful, Ruskin will report an error in the Status column.
.

.

To view connected GPS devices, go to the next utility. 

View connected GPS...

This feature allows you to track your instruments during towed deployments. Attach a NMEA GPS to your computer and 
connect to it as described above. Alternatively, connect to one of the boat tracking devices if it has an IP address.

Typically, only one GPS is necessary to track your deployment. Using more than one GPS may bring confusion into your 
data. Click View connected GPS... to see all listening ports. Click the Port button to disconnect. 
.
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20 User calibration
Factory calibration coefficients are calculated for each sensor, and the coefficients are stored on the instrument. 

RBR calibration certificates contain calibration equations, coefficients, and residuals for each sensor. Calibration 
certificates are available for download:

• If using Ruskin, connect your instrument and go to the “Information” tab, then click “Download" at the bottom

• For OEM instruments, go to https://oem-lookup.RBR-global.com, middle tab, and search by the serial number and 
authorisation key

RBR recommends calibrating your instrument before any critical deployment, periodically once a year, or if you suspect 
the readings to be out of specifications.

Discuss your calibration requirements with RBR. In some cases, the instrument will need to be returned to RBR to have 
it checked and recalibrated.

Please contact RBR for our current calibration fees. 

View current calibration coefficients for your sensors under the Calibration tab in the Properties window. 

Dissolved oxygen sensors can be field-calibrated.  Update the calibration coefficients for these channels periodically. 
On occasion, you may need to manually enter new coefficients, although this is not recommended for factory-
calibrated sensors (for example, T or D) unless instructed by RBR.

To calibrate a sensor, you need to let it sample in a known environment and then compare the result to the established 
value.  The difference will be used to generate calibration coefficients. With the N-point method, the known 
environment is changed N times. The higher the N, the more accurate are calibration coefficients. 

Use the Calibration button under the Analysis tab to calibrate galvanic dissolved oxygen sensors (the RBRcoda3 DO).

Use the Plot window to calibrate RBR optical dissolved oxygen sensors (the RBRcoda3 T.ODO) and RBR tubidity sensors 
(the RBRcoda Tu).

When performing a one-point calibration, Ruskin will adjust the coefficients as follows.
Zero-point calibration: 

20.1 Dissolved oxygen sensor calibration
RBR streaming sensors with dissolved oxygen sensors include the RBRcoda3 T.ODO, with optical dissolved oxygen 
sensors manufactured by RBR, and the RBRcoda3 DO with galvanic dissolved oxygen sensors manufactured by 
OxyGuard. 

For dissolved oxygen sensors, RBR recommends user calibration using the N-point method, with N = 2, which will 
include a zero reference point and a non-zero reference point. It is, however, acceptable to perform a one-point 
calibration.  

20.1.1 Dissolved oxygen data collection
The steps to obtain the calibration dataset are the same for DO and ODO sensors. The only difference is that optical 
sensors must be hydrated before use. Thus, if you store it with a wet storage cap on, your instrument is ready for 
calibration any time. However, if you store it dry, rehydrate your sensor for five days. It takes at least three days for a dry 
ODO sensor to equilibrate after being placed in water. Insufficient hydrating time may lead to unreliable data. See "RBR 
ODO sensor care and maintenance" section in the RBR Standard Instrument Guide for more details. The Guide is 
available on Ruskin under Help > Documentation. 

Non-zero point calibration: 

mailto:support@rbr-global.com
https://oem-lookup.RBR-global.com
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•

1.
2.
3.
4.

1.
2.
3.
4.
5.

A wide-mouth, black-walled container with a cover
A small container or beaker
Air pump (for example, an aquarium air pump with a stone bubbler) 
Magnetic stirrer
Sodium sulphite Na2SO3
Distilled water

Ruskin configuration
Go to Configuration .
Select UTC or Local, depending on your preferences, to synchronise the instrument clock with your computer.
Set the sampling rate at 1s (1Hz).
Enable your schedule.

Non-zero reference point

Fill the black-walled container with distilled water.
Install the magnetic stirrer.
Install the air pump.
Switch on both the air pump and the magnetic stirrer.
Leave them on overnight, or for at least 3-4 hours, to achieve saturation. 

The instrument must be logging throughout the calibration procedure.

 Rehydrate the RBRcoda3 T.ODO for five days before collecting data..

The RBRcoda3 DO instruments with galvanic dissolved oxygen sensors manufactured by OxyGuard do not need 
hydrating. 

Equipment and materials



RBR#0003296revP 87

6.

7.

8.

1.

2.
3.

4.

Submerge the dissolved oxygen sensor in the solution, going in at an angle and stirring to avoid bubble buildup 
on the sensor window. 
Leave some space between the sensor and the beaker walls. 
Position the sensor near the stirrer but not directly in the bubbles. 
The bubbler should be shallower than the sensor.
Record the data for at least 30 minutes.
This is the 100% oxygen concentration calibration point.

Zero reference point

In a small container or beaker, prepare a 0.1% solution of sodium sulphite (0.25g of Na2SO3 for 250mL tap 
water). 
Mix the solution thoroughly with a magnetic stirrer. The solution will be oxygen-free after 15 minutes. 
Submerge the dissolved oxygen sensor in the solution, going in at an angle and stirring to avoid bubble buildup 
on the sensor window. 
Leave some space between the sensor and the beaker walls. 

Record the data for at least 30 minutes.
This is the 0% oxygen concentration calibration point.

.

Omit this step when performing the one-point calibration. 
If you calibrate your dissolved oxygen sensor using the one-point calibration method at 100% oxygen 
concentration only, calibration should be performed at the expected temperature and salinity of the 
deployment environment.



This Na2SO3 solution has a limited lifespan and should not be used for more than a day. 
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1.

2.

3.

4.

5.

20.1.2 DO calibration in Analysis tab
For DO sensors, RBR recommends a two-point user calibration, which includes a zero reference point  and a non-zero 
reference point. It is, however, acceptable to use a one-point calibration. 

Two-point calibration steps on Ruskin 
Stop the deployment.

Download the dataset.

Open the dataset on Ruskin. The Properties windows will change to dataset properties, with the Analysis tab 
displayed.

.

Click Calibration. 

Select Dissolved O2 saturation  from the dropdown list.
By default, the Number of samples  is set to 100, which means Ruskin will average the calibration coefficients 
over a hundred sample points. Typically, this value should be in the range from 50 to 100 samples.
The Raw channel box is unchecked, and thus the true DO values will be displayed in the plot below. To see the 
raw voltage values, check this box. 
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6.

7.

A downsampled representation of the dataset will appear in the thumbnail view, with two distinct plateaus 
corresponding to 100% and 0%. Irregular readings in-between mark the times when you changed from distilled 
water to sodium sulphite solution and reassembled the setup. 

Click on a stable point in the Plot view corresponding to 100% oxygen. 

The interval of 100 samples will be highlighted. The average value (Avg) and standard error (Std) for this interval 
will appear in the table above. 

Under Real Avg  in the first row, enter 100. 
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8.
9.

10.
11.
12.
13.
14.
15.

Repeat the same steps for the second plateau, entering 0 under Real Avg.
Ruskin automatically calculates the calibration coefficients, and the values appear in Calculated coefficients. 

Click Copy to save the new calibration coefficients to the clipboard, or write them down.
In the Navigator view, find your instrument.
Click  Calibration and select Dissolved O2 saturation  from the dropdown list. 
Click C0 to select the entry field and type in the new value (in this example, -2.6351535 ). 
Click C1  to select the entry field and type in the new value (in this example, 1.0794960 ).
Click Store calibration to save the new coefficients. 

Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will be lost 
once your session is closed. 


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3.

4.

5.

6.

7.

8.

9.

10.

11.

12.

13.

14.

One-point calibration steps on Ruskin

Stop the deployment.

Download the dataset.

Open the dataset on Ruskin. The Properties windows will change to dataset properties, with the Analysis tab 
displayed.

Click Calibration. 

Select Dissolved O2 saturation from the dropdown list.

Check the 1 point calibration box. 

Click on a stable point in the Plot view corresponding to 100% oxygen. 
The interval of 100 samples will be highlighted. The average value (Avg) and standard error (Std) for this interval 
will appear in the table above. 

Click the RealAvg column and select 100 from the dropdown. 

Click Copy to save the new calibration coefficients to the clipboard, or write them down.

In the Navigator view, find your instrument.

Click Calibration and select Dissolved O2 saturation from the dropdown list. 

Click C0 to select the entry field and type in the new value. 

Click C1 to select the entry field and type in the new value.

Click Store calibration to save the new coefficients. 

If you calibrate your dissolved oxygen sensor using the single-point calibration method at 100% oxygen 
concentration only, calibration should be performed at the expected temperature and salinity of the 
deployment environment.



Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will be lost 
once your session is closed. 


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1.
a.

b.

c.

d.

20.1.3 ODO calibration in Plot window

Plot calibration steps on Ruskin

Use the Plot window on Ruskin to calibrate your RBRcoda3 T.ODO. You can choose a one-point (100% O2) or a two-
point  (100% and 0% O2) method.

Create a new calibration region.
Obtain the calibration dataset as described above and open it in Ruskin. 

Click Create annotation  and select Calibration from the dropdown menu.

The cursor in the Plot window will become a two-way arrow   .

Click and drag left or right to select the calibration region. 
The interval will be highlighted and a tooltip will open. 

Enter the title for the region and select Dissolved O2 concentration from the dropdown menu. 

Optical dissolved oxygen sensors manufactured by RBR are calibrated using the Plot window.  Clicking the 
Calibration button under the Analysis tab will result in an error message.


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e.

f.

2.

a.

b.

Press Enter on your keyboard or click Save   on the tooltip to save the calibration region. 
A section for this calibration region will open under Cursor. 

To delete a calibration region, click Delete  on the tooltip. 
A warning message will appear.

Create plateaus.

Click Detect plateaus  on the tooltip to launch the automatic selection process. 
If there are existing plateaus, a warning message will appear.

Click Proceed to continue. 
All detected plateaus will be visible as grey markers under the calibration region marker.  
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c.

d.

e.

3.
a.

To create a plateau manually, click Create plateaus  on the tooltip. 
A new plateau will appear as a grey marker at the start of the calibration region marker. Each new 
click will add another plateau to the right of the existing one. 

Click a plateau to open its tooltip. You can now edit the title and add reference values.

To delete a plateau, click Delete   on the tooltip. 
A warning message will appear.

Enter reference data.
By default, Reference is set to Manual entry mode, with in units of % or  μm ol/L available in the 
dropdown menu. 

Enter the reference value for each plateau manually in the Plateau table under Cursor:
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b.

or in the Plateau tooltip: 

Alternatively, enter reference values from the CSV file. 
The CSV file for the automatic data entry must have two columns: time (in ISO 8601 format) and 
data (in float/double format). For example:

Once the file has been selected, a dialogue box will appear asking for you to define which column 
contains the time and which contains the reference values.

The time in the CSV file will need to be a value that falls within the region of the plateau.
However, the CSV file can hold additional rows with times that are outside of the plateau 
region.


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4.

a.

b.

Save the coefficients.

Verify that the calibration was successful.
If the residuals are within an acceptable range, they will be highlighted in green, and the Save button will 
appear in the Calculated coefficients section.

Click Save to write the coefficients to the instrument. The instrument must be connected to Ruskin.

If successful, a success message will appear. 

If not, a warning message will appear instead. 

Calibration coefficients are stored on the instrument and not the sensor.  Recalibrate your sensor if you move 
it to a different instrument. 


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20.2 Turbidity sensor calibration
Turbidity sensors manufactured by RBR are available as the RBRcoda Tu.

RBR factory-calibrates the turbidity sensors using the N-point method, with N = 2. For user calibration, we also 
recommend using the two-point method (N = 2) performed with protection from ambient light.

20.2.1 Tu data collection
Follow the steps below to obtain the calibration dataset for your Tu sensor. 

Equipment and materials
A wide-mouth, black-walled container (large enough to hold the instrument 15-20cm away from the walls) 
Secure black lid for the container with an orifice for the instrument
Small black lid or any light-blocking material to cover the orifice during calibration
1000FTU Formazin standard (800-1000FTU will work)
Optional: 4000FTU Formazin standard (for the optical backscatter channel)
Distilled water
Large magnetic stirrer
Rubbing alcohol
Soft cloth

Ruskin configuration
Go to Configuration.
Use Local on Ruskin to synchronise the instrument clock with your computer.
Set the sampling rate to 4Hz.
Enable your schedule.

The RBRcoda Tu has two channels, turbidity and optical backscatter. It is not mandatory to calibrate both if 
you are only using one. However, if you are using the OBS channel and need to calibrate it, use two non-zero
reference points. 

The instrument must be logging throughout the calibration procedure.

1.
2.

3.

Sensor preparation

Wash the sensor and container with distilled water and dry them with a soft cloth.
Check the turbidity window for stains and scratches. 

Do not proceed with calibration if there are serious scratches.

.
Wipe the  turbidity window with alcohol to remove all stains.  
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1.
2.
3.
4.

5.
6.

Zero reference point

Fill the black-walled container with distilled water.
Turn on the magnetic stirrer and adjust the RPM to ensure no vortex appears. 
Place the black lid on the container and avoid direct light on the container.
Submerge the sensor though the orifice in the lid, vertically along the wall,  with the turbidity window facing the 
larger water volume. 

Non-zero reference point

Repeat the steps for the zero reference point, replacing distilled water with 1000FTU Formazin standard.

This is the 1000NTU calibration point.

As each reference point takes 15 minutes to an hour, the entire procedure may take up to two hours. 

After completing the procedure for both reference points (or for a single reference point, if using the one-point method), 
proceed to calibration on Ruskin. 

The distance from the turbidity window to the container wall must be 15-20cm. 

.
Cover the orifice with the smaller black lid or light-blocking material, like a thick plastic bag.  
Record the data in distilled water for at least 15min, up to 45min. 

This is the zero-turbidity calibration point.

If you are calibrating the OBS channel (RBRcoda Tu), repeat these steps for one more non-zero point 
(4000FTU).  Thus, you will have two non-zero points (1000FTU and 4000FTU), but no zero points.

 If a non-zero reference solution is produced by diluting concentrated Formazin, stir until stable.
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1.
a.

b.

c.

d.

e.

20.2.2 Tu calibration in Plot window

Plot calibration steps on Ruskin

Use the Plot window on Ruskin to calibrate your RBRcoda Tu. You can choose a one-point (1000FTU) or a two-point  
(distilled water and 1000FTU) method.

Create a new calibration region.
Obtain the calibration dataset as described above and open it in Ruskin. 

Click Create annotation  and select Calibration from the dropdown menu.

The cursor in the Plot window will become a two-way arrow   .

Click and drag left or right to select the calibration region. 
The interval will be highlighted and a tooltip will open. 

Enter the title for the region and select the channel to calibrate from the dropdown menu: Turbidity 
880nm or Turbidity OBS 880nm. 

Press Enter on your keyboard or click Save   on the tooltip to save the calibration region. 
A section for this calibration region will open under Cursor. 

Turbidity sensors manufactured by RBR are calibrated using the Plot window.  Clicking the Calibration button 
under the Analysis tab will result in an error message.
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f.

2.

a.

b.

c.

To delete a calibration region, click Delete  on the tooltip. 
A warning message will appear.

Create plateaus.

Click Detect plateaus  on the tooltip to launch the automatic selection process. 
If there are existing plateaus, a warning message will appear.

Click Proceed to continue. 
All detected plateaus will be visible as grey markers under the calibration region marker.  

To create a plateau manually, click Create plateaus  on the tooltip. 
A new plateau will appear as a grey marker at the start of the calibration region marker. Each new click 
will add another plateau to the right of the existing one. 
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d.

e.

3.
a.

Click a plateau to open its tooltip. You can now edit the title and add reference values.

To delete a plateau, click Delete   on the tooltip. 
A warning message will appear.

Enter reference data.
By default, Reference is set to 0.0 entry mode. Enter the reference value for each plateau manually in the 
Plateau table under Cursor:
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b. Alternatively, enter reference values from the CSV file. 
The CSV file for the automatic data entry must have two columns: time (in ISO 8601 format) and data (in
float/double format). For example:

Once the file has been selected, a dialogue box will appear asking for you to define which column 
contains the time and which contains the reference values.

The time in the CSV file will need to be a value that falls within the region of the plateau.
However, the CSV file can hold additional rows with times that are outside of the plateau region.

or in the Plateau tooltip: 
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4.

a.

b.

Save the coefficients.

Verify that the calibration was successful.
If the residuals are within an acceptable range, they will be highlighted in green, and the Save button will 
appear in the Calculated coefficients section.

Click Save to write the coefficients to the instrument. The instrument must be connected to Ruskin.

If successful, a success message will appear. 

If not, a warning message will appear instead. 
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22 Revision history
Revision No. Release Date Notes

1.0 - H 2011-2020 Various

J 31-August-2022 Restructured the user guide to reflect Ruskin interface, added a 
dedicated page for RSK files, edited existing instructions for 
clarity, removed outdated sections and screenshots. Added 
RBRtridente to Realtime output format and OEM command 
reference (channel types). 

K 31-December-2022 Added a section on the Search option under Support (for Mac 
users). Updated the RSK files and File info sections to reflect 
new file structure labels. Enhanced Plot window instructions. 
Updated the Power section. Added RBRquadrante, RBRcoda Tu 
to Realtime output format and OEM command reference 
(channel types). Added the config command (restoring factory 
configuration) for the RBRtridente. Corrected typos in the User 
calibration section. 

L 31-March-2023 Added/updated screenshots in several sections (Ruskin 
interface, Simulate an instrument, Configuration, and 
Appearance controls) for clarity. Added information on 
synchonising the instrument clock in the Schedule section. 
Added the Connections page. Corrected a typo in the Tide 
section. Added Ranging sensors (RBRcoda Tu). Updated the 
Analysis, Annotation controls, and Zoom controls sections.  
Added the Utilities page. 

M 31-May-2023 Updated the Configure as sensor section. 

N 31-October-2023 Updated the Information section to include guidance on 
downloading the latest calibration certificates. Updated the list 
of Supported channel types for the new RBRtridente channels.

P 31-December-2024 Added aggregate mode to Sampling. Added user calibration 
instructions for the RBRcoda Tu. Removed the OEM command 
reference section (now available as a separate document, 
"Sensor Command Reference"). 
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